Bitcoin client configuration in the Docker


#1

Hi Everyone!
So far I’ve managed to run the cert-viewer, the cert-tool to create and manage certificates, and the cert-issuer but only in the docker image and on regtest mode.
Does anyone know how to configure the bitcoin client in the docker image to change it to testnet? I havent found the Bitcoin.conf file, so I created one and place it in the “bitcoin” folder, but that didnt change from regtest to testnet.
The other thing I’ve tried is to run the cert-isuer outside the docker image, but Im getting the “Not enough satoshis” error even though there are plenty in my bitcoin-cli runing on my pc. Does anyone know how can I connect the Issuer to my bitcoin client?
Thanks in advance
Julian


#2

Typically when running from the docker image, you’ll run testnet/mainnet in broadcast mode, without using bitcoind. Check out this link to our wiki for more info on setting up the cert-issuer config.

For setting up with a local bitcoind, follow these instructions: https://github.com/blockchain-certificates/cert-issuer/blob/master/docs/bitcoind.md#local-bitcoin-node-instructions

If those don’t help, let us know.


#3

Thanks @aronning!
A few hours ago I manage to do my first testnet transaction, here is the txd_id:
https://testnet.blockchain.info/tx/8d3779c5747ffc9b23f55d2dd779b01da85aada3448a3ee2588c4dae0545be17?show_adv=true
Thanks for all the help :slight_smile:


#4

Congrats! You’re welcome, exciting stuff!