[V3] Errors with cert-issuer on Docker

Hi everyone,

I’m creating a new product and I’m looking to have Blockcerts to be a part of it.
I’m trying to run the cert-issuer but I’m having problems with the instructions in the repo’s README.

When I run docker run, after building the container I get the following error:
"Error: Config setting for -rpcport only applied on regtest network when in [regtest] section."

It seems this is related to the bitcoin side of things but I’m pretty new with all this and as I have no indications on where the error is coming from I have no idea how to fix it.

I’ve seen the same error in the thread below, but no ways to fix it:

Can anyone help a newb in need?

Thank you


I was able to solve my own problem.
It seems that for the bitcoin configurations to work, you need to add a [regtest] to the top of the bitcoin.conf. That will fix the error.

The change is in the Dockerfile

$‘rpcuser=foo\nrpcpassword=bar\nrpcport=8332\nregtest=1\nrelaypriority=0\nrpcallowip=\nrpcconnect=\n’ > /root/.bitcoin/bitcoin.conf \


$‘[regtest]\nrpcuser=foo\nrpcpassword=bar\nrpcport=8332\nregtest=1\nrelaypriority=0\nrpcallowip=\nrpcconnect=\n’ > /root/.bitcoin/bitcoin.conf \

I’ve also sent a Pull Request with the fix

Thanks @dallarosa for figuring out the issue and your contribution