That certificate didn't load correctly, so it can't be validated


#1

Hi

I am using the blockcerts standard to issue certificates on the bitcoin testnet. I followed the instructions from the cert-issuer page and successfully issued some certificates to this testnet.

I am however, getting the following error “That certificate didn’t load correctly, so it can’t be validated” when I try to view these certificates from a browser, using the cert-web-components. The sample certificate “sample_cert-valid-2.0.json” from the demo folder under cert-web-components was validated without issues.

Could you please give me some suggestions on why I might be getting this specific error? Any help is appreciated.


#2

Hi Ruth,

I’d be curious to know what happens when you submit the certificate to the verifier on https://blockcerts.org. Is there any difference in behavior?


#3

Hi, apologies for the late reply, I recently just got around to trying the fix but your suggestion was actually very useful. At the time I posted the question, my certificates turned out to be a mess because of my issuer profile not being set up properly. I have since fixed that and I can now issue certificates that are valid when I run them through blockcerts’ verifier. I am however still getting the same error from the cert-web-component. I have installed the cert-viewer flask application and validated the same certificates successfully from there as well.

So the same blockchain certificates that are valid from blockcerts’ verifier and the cert-viewer app still give the error “That certificate didn’t load correctly, so it cant be validated” with the cert-web-component. The sample certificate still displays without problems though. I’ve tried to identify the differences between the sample certificate json and one of mine, it seems the sample certificate is a blockcerts version 1 certificate. I do not know if I am correct but since I use the version 2 python module “create_v2_certificate_template.py” to create the certificate templates, could it be possible that the cert-web-component expects some kind of structure/format that has since changed from the initial version 1 module?

Thank you again for the help, at the very least I can be sure the blockchain certificates are now valid.


#4

Hmm… I wonder what’s going on there. The cert-web-component definitely should work with v2 Blockcerts, but if there’s a bug, I’d like to know more about it. You don’t happen to see a stack trace anywhere, by chance?