Question of installing cert-issuer


#1

Hi,

I’m trying to set up enviroment in virtualbox ubuntu14.04 os.
I set up python virtual environment and use python 3.5.2 version.

when I’m installing cert-issuer, the process report no error or other information.seems to be successful.
but when running cert-issuer -c conf.ini, there is error saying no command was found.
How to fix the problem.
Thanks a lot!

The info after running “python setup.py experimental --blockchain=ethereum” is as follows:
//
(certviewervenv) jack@VUBUNTU1404:~/cert-issuer$ python setup.py experimental --blockchain=ethereum
running experimental
Requirement already satisfied: cert-core>=2.1.9 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (2.1.9)
Requirement already satisfied: jsonschema>=2.6.0 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from cert-core>=2.1.9) (2.6.0)
Requirement already satisfied: requests>=2.18.4 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from cert-core>=2.1.9) (2.21.0)
Requirement already satisfied: python-dateutil>=2.6.1 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from cert-core>=2.1.9) (2.8.0)
Requirement already satisfied: tox>=3.0.0 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from cert-core>=2.1.9) (3.7.0)
Requirement already satisfied: cert-schema>=2.1.5 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from cert-core>=2.1.9) (2.1.6)
Requirement already satisfied: Flask-PyMongo>=0.5.1 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from cert-core>=2.1.9) (2.2.0)
Requirement already satisfied: pytz>=2017.2 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from cert-core>=2.1.9) (2018.9)
Requirement already satisfied: validators>=0.12.1 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from cert-core>=2.1.9) (0.12.4)
Requirement already satisfied: connexion>=1.1.14 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from cert-core>=2.1.9) (2.2.0)
Requirement already satisfied: configargparse>=0.12.0 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from cert-core>=2.1.9) (0.12.0)
Requirement already satisfied: simplekv>=0.10.0 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from cert-core>=2.1.9) (0.11.11)
Requirement already satisfied: certifi>=2017.4.17 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from requests>=2.18.4->cert-core>=2.1.9) (2018.11.29)
Requirement already satisfied: urllib3<1.25,>=1.21.1 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from requests>=2.18.4->cert-core>=2.1.9) (1.24.1)
Requirement already satisfied: idna<2.9,>=2.5 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from requests>=2.18.4->cert-core>=2.1.9) (2.8)
Requirement already satisfied: chardet<3.1.0,>=3.0.2 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from requests>=2.18.4->cert-core>=2.1.9) (3.0.4)
Requirement already satisfied: six>=1.5 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from python-dateutil>=2.6.1->cert-core>=2.1.9) (1.12.0)
Requirement already satisfied: virtualenv>=1.11.2 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from tox>=3.0.0->cert-core>=2.1.9) (16.4.0)
Requirement already satisfied: toml>=0.9.4 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from tox>=3.0.0->cert-core>=2.1.9) (0.10.0)
Requirement already satisfied: pluggy<1,>=0.3.0 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from tox>=3.0.0->cert-core>=2.1.9) (0.8.1)
Requirement already satisfied: filelock<4,>=3.0.0 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from tox>=3.0.0->cert-core>=2.1.9) (3.0.10)
Requirement already satisfied: setuptools>=30.0.0 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from tox>=3.0.0->cert-core>=2.1.9) (40.8.0)
Requirement already satisfied: py<2,>=1.4.17 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from tox>=3.0.0->cert-core>=2.1.9) (1.7.0)
Requirement already satisfied: pyld>=1.0.3 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from cert-schema>=2.1.5->cert-core>=2.1.9) (1.0.4)
Requirement already satisfied: PyMongo>=3.0 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from Flask-PyMongo>=0.5.1->cert-core>=2.1.9) (3.7.2)
Requirement already satisfied: Flask>=0.11 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from Flask-PyMongo>=0.5.1->cert-core>=2.1.9) (1.0.2)
Requirement already satisfied: decorator>=3.4.0 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from validators>=0.12.1->cert-core>=2.1.9) (4.3.2)
Requirement already satisfied: PyYAML>=3.13 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from connexion>=1.1.14->cert-core>=2.1.9) (3.13)
Requirement already satisfied: openapi-spec-validator>=0.2.4 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from connexion>=1.1.14->cert-core>=2.1.9) (0.2.4)
Requirement already satisfied: clickclick>=1.2 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from connexion>=1.1.14->cert-core>=2.1.9) (1.2.2)
Requirement already satisfied: typing>=3.6.1; python_version < “3.6” in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from connexion>=1.1.14->cert-core>=2.1.9) (3.6.6)
Requirement already satisfied: inflection>=0.3.1 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from connexion>=1.1.14->cert-core>=2.1.9) (0.3.1)
Requirement already satisfied: click>=5.1 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from Flask>=0.11->Flask-PyMongo>=0.5.1->cert-core>=2.1.9) (7.0)
Requirement already satisfied: itsdangerous>=0.24 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from Flask>=0.11->Flask-PyMongo>=0.5.1->cert-core>=2.1.9) (1.1.0)
Requirement already satisfied: Jinja2>=2.10 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from Flask>=0.11->Flask-PyMongo>=0.5.1->cert-core>=2.1.9) (2.10)
Requirement already satisfied: Werkzeug>=0.14 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from Flask>=0.11->Flask-PyMongo>=0.5.1->cert-core>=2.1.9) (0.14.1)
Requirement already satisfied: MarkupSafe>=0.23 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from Jinja2>=2.10->Flask>=0.11->Flask-PyMongo>=0.5.1->cert-core>=2.1.9) (1.1.0)
Requirement already satisfied: cert-schema>=2.1.5 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (2.1.6)
Requirement already satisfied: validators>=0.12.1 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from cert-schema>=2.1.5) (0.12.4)
Requirement already satisfied: jsonschema>=2.6.0 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from cert-schema>=2.1.5) (2.6.0)
Requirement already satisfied: pyld>=1.0.3 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from cert-schema>=2.1.5) (1.0.4)
Requirement already satisfied: requests>=2.18.4 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from cert-schema>=2.1.5) (2.21.0)
Requirement already satisfied: tox>=3.0.0 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from cert-schema>=2.1.5) (3.7.0)
Requirement already satisfied: six>=1.4.0 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from validators>=0.12.1->cert-schema>=2.1.5) (1.12.0)
Requirement already satisfied: decorator>=3.4.0 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from validators>=0.12.1->cert-schema>=2.1.5) (4.3.2)
Requirement already satisfied: certifi>=2017.4.17 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from requests>=2.18.4->cert-schema>=2.1.5) (2018.11.29)
Requirement already satisfied: chardet<3.1.0,>=3.0.2 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from requests>=2.18.4->cert-schema>=2.1.5) (3.0.4)
Requirement already satisfied: urllib3<1.25,>=1.21.1 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from requests>=2.18.4->cert-schema>=2.1.5) (1.24.1)
Requirement already satisfied: idna<2.9,>=2.5 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from requests>=2.18.4->cert-schema>=2.1.5) (2.8)
Requirement already satisfied: py<2,>=1.4.17 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from tox>=3.0.0->cert-schema>=2.1.5) (1.7.0)
Requirement already satisfied: virtualenv>=1.11.2 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from tox>=3.0.0->cert-schema>=2.1.5) (16.4.0)
Requirement already satisfied: toml>=0.9.4 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from tox>=3.0.0->cert-schema>=2.1.5) (0.10.0)
Requirement already satisfied: filelock<4,>=3.0.0 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from tox>=3.0.0->cert-schema>=2.1.5) (3.0.10)
Requirement already satisfied: setuptools>=30.0.0 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from tox>=3.0.0->cert-schema>=2.1.5) (40.8.0)
Requirement already satisfied: pluggy<1,>=0.3.0 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from tox>=3.0.0->cert-schema>=2.1.5) (0.8.1)
Requirement already satisfied: chainpoint>=0.0.2 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (0.0.2)
Requirement already satisfied: merkletools==1.0.2 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from chainpoint>=0.0.2) (1.0.2)
Requirement already satisfied: pysha3>=1.0b1 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from merkletools==1.0.2->chainpoint>=0.0.2) (1.0.2)
Requirement already satisfied: configargparse>=0.12.0 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (0.12.0)
Requirement already satisfied: glob2==0.6 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (0.6)
Requirement already satisfied: mock==2.0.0 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (2.0.0)
Requirement already satisfied: six>=1.9 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from mock==2.0.0) (1.12.0)
Requirement already satisfied: pbr>=0.11 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from mock==2.0.0) (5.1.2)
Requirement already satisfied: requests[security]>=2.18.4 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (2.21.0)
Requirement already satisfied: idna<2.9,>=2.5 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from requests[security]>=2.18.4) (2.8)
Requirement already satisfied: urllib3<1.25,>=1.21.1 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from requests[security]>=2.18.4) (1.24.1)
Requirement already satisfied: certifi>=2017.4.17 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from requests[security]>=2.18.4) (2018.11.29)
Requirement already satisfied: chardet<3.1.0,>=3.0.2 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from requests[security]>=2.18.4) (3.0.4)
Requirement already satisfied: pyOpenSSL>=0.14; extra == “security” in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from requests[security]>=2.18.4) (17.5.0)
Requirement already satisfied: cryptography>=1.3.4; extra == “security” in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from requests[security]>=2.18.4) (2.5)
Requirement already satisfied: six>=1.5.2 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from pyOpenSSL>=0.14; extra == “security”->requests[security]>=2.18.4) (1.12.0)
Requirement already satisfied: asn1crypto>=0.21.0 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from cryptography>=1.3.4; extra == “security”->requests[security]>=2.18.4) (0.24.0)
Requirement already satisfied: cffi!=1.11.3,>=1.8 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from cryptography>=1.3.4; extra == “security”->requests[security]>=2.18.4) (1.12.0)
Requirement already satisfied: pycparser in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from cffi!=1.11.3,>=1.8->cryptography>=1.3.4; extra == “security”->requests[security]>=2.18.4) (2.19)
Requirement already satisfied: pycoin>=0.80 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (0.80)
Requirement already satisfied: pyld>=1.0.3 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (1.0.4)
Requirement already satisfied: pysha3>=1.0.2 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (1.0.2)
Requirement already satisfied: python-bitcoinlib>=0.10.1 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (0.10.1)
Requirement already satisfied: tox>=3.0.0 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (3.7.0)
Requirement already satisfied: setuptools>=30.0.0 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from tox>=3.0.0) (40.8.0)
Requirement already satisfied: filelock<4,>=3.0.0 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from tox>=3.0.0) (3.0.10)
Requirement already satisfied: toml>=0.9.4 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from tox>=3.0.0) (0.10.0)
Requirement already satisfied: pluggy<1,>=0.3.0 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from tox>=3.0.0) (0.8.1)
Requirement already satisfied: virtualenv>=1.11.2 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from tox>=3.0.0) (16.4.0)
Requirement already satisfied: py<2,>=1.4.17 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from tox>=3.0.0) (1.7.0)
Requirement already satisfied: six<2,>=1.0.0 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from tox>=3.0.0) (1.12.0)
Requirement already satisfied: coincurve==7.1.0 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (7.1.0)
Requirement already satisfied: asn1crypto in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from coincurve==7.1.0) (0.24.0)
Requirement already satisfied: cffi>=1.3.0 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from coincurve==7.1.0) (1.12.0)
Requirement already satisfied: pycparser in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from cffi>=1.3.0->coincurve==7.1.0) (2.19)
Requirement already satisfied: ethereum==2.3.1 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (2.3.1)
Requirement already satisfied: pyethash in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from ethereum==2.3.1) (0.1.27)
Requirement already satisfied: rlp>=0.4.7 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from ethereum==2.3.1) (0.6.0)
Requirement already satisfied: pysha3>=1.0.1 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from ethereum==2.3.1) (1.0.2)
Requirement already satisfied: PyYAML in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from ethereum==2.3.1) (3.13)
Requirement already satisfied: coincurve>=7.0.0 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from ethereum==2.3.1) (7.1.0)
Requirement already satisfied: future in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from ethereum==2.3.1) (0.17.1)
Requirement already satisfied: pbkdf2 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from ethereum==2.3.1) (1.3)
Requirement already satisfied: repoze.lru in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from ethereum==2.3.1) (0.7)
Requirement already satisfied: pycryptodome>=3.4.7 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from ethereum==2.3.1) (3.7.3)
Requirement already satisfied: py-ecc in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from ethereum==2.3.1) (1.4.7)
Requirement already satisfied: scrypt in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from ethereum==2.3.1) (0.8.13)
Requirement already satisfied: asn1crypto in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from coincurve>=7.0.0->ethereum==2.3.1) (0.24.0)
Requirement already satisfied: cffi>=1.3.0 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from coincurve>=7.0.0->ethereum==2.3.1) (1.12.0)
Requirement already satisfied: pycparser in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (from cffi>=1.3.0->coincurve>=7.0.0->ethereum==2.3.1) (2.19)
Requirement already satisfied: rlp<1 in /home/jack/cvenv/certviewervenv/lib/python3.5/site-packages (0.6.0)
(certviewervenv) jack@VUBUNTU1404:~/cert-issuer$ ls


#2

That is because you need to install the cert-issuer command.
While at cert-issuer’s path run pip3 install . and then run cert-issuer -c conf.ini it should be working.