Ethereum Cert-issuer installation error


I’m trying to install cert-issuer on a fresh installation of Ubuntu 18.04.1
So i run the command “python3 experimental --blockchain=ethereum” and the installation stopped with an error same as the below picture but with coincurve instead of requests[security].

Then i immediately run the same command again and get a different error this time (see below picture)

Re-running the command i am stuck at the same error. I tried running “python3 -m pip install requests[security]>=2.18.4” but i get a “segmentation fault (core dumped)” error. What could be the case?

Any help is much appreciated.

Are you running this in virtualenv?

No, i’m not. But i don’t know how to either

Check out

Thank you. I used virtualenv and it installed just fine. But when i run cert-issuer -c conf.ini i get the same error as this post: ERROR of "cert-issuer -c /etc/cert-issuer/conf.ini"

EDIT : I get the error right after the message for obtaining the transaction ID. Also i can see my transaction on etherscan

Apparently if running sudo python3 experimental --blockchain=ethereum outside of virtulenv instead of python3 experimental --blockchain=ethereum i don’t get any errors. But then again when running cert-issuer -c conf.ini i get the same error as virtualenv (AttributeError: ‘tuple’ object has no attribute ‘unsigned_cert_file_name’).

Can anyone please help?

Looks like someone from the community has fixed this:

Could you try getting the latest version of the code and trying again?

Yeah, i figured it was an error in the code somewhere. I downloaded a previous version and it worked just fine. Good to know you fixed this in the latest version.