Merkletools dependences pysha3

Hi there!

I’m trying to install cert-issuer, but when I run “python install”, I get the following error:

Processing dependencies for cert-issuer==2.0.11
error: pysha3 1.0.2 is installed but pysha3==1.0b1 is required by {‘merkletools’}

I’m running on a Windows, virtualenv enabled for python 3.6.3. This question is the same that appeared in a different thread (No module named ‘cert_issuer’), but it looks like remain unanswered. Could somebody please give me a hint about how to solve it?



Ok, solved by now in *WINDOWS". I don’t know whether it is the best way or not, but that’s how I went over it:

  • Good to know, the issue is about two conflicting libraries in the project. Merkletools requires “exactly” pysha3 1.01b, while cert-tools require pysha3 1.0.2 or greater
  • I used “pip install cert-issuer” instead “python install”
  • I tried the force-brute approach: I went to C:\Users"user"\AppData\Local\Programs\Python\Python36\Lib\site-packages\merkletools-1.0.2-py3.6.egg\EGG-INFO, and open “requires.txt” with a text editor (wordpad will do). Change the contents inside to pysha3==1.0.2 (maybe >= would be better)

That’s all. Sure, there should be better ways to solve the problem…

1 Like

Hi Guys,
Im facing the same problem in mac os.
Processing dependencies for cert-issuer==2.0.12
error: pysha3 1.0.2 is installed but pysha3==1.0b1 is required by {‘merkletools’}

I´ve already run pip install cert-issuer and python 2 install but both didnt for for me.

1 Like


For the time being, try using the above approach. There’s some clashing going on with some dependencies, and the docker image seems to take care of it manually with this line:

sed -i.bak s/==1\.0b1/\>=1\.0\.2/g /usr/lib/python3.*/site-packages/merkletools-1.0.2-py3.*.egg-info/requires.txt

Alternatively, another approach is to manually update chainpoint’s dependency to 1.0.3. Unfortunately I do not know why it’s trying to use a previous version of merkeltools.

vi /usr/local/lib/python3.6/site-packages/chainpoint-0.0.2.dist-info/METADATA

Change to merkletools (==1.0.2) to merkletools (>=1.0.3)

Opened up an issue tracking it here:


I am using Mac OS too.

There is no requires.txt file in /site-packages/merkletools-1.0.2-py3.*.egg-info folder. I tried changing the chainpoint METADATA file too. But it still shows the same issue.

I am getting this error when I run cert-issuer -c conf.ini

pkg_resources.ContextualVersionConflict: (pysha3 1.0.2 (/Users/kjallawaram/Karthik/BlockChain/cert-issuer/venv/lib/python3.6/site-packages), Requirement.parse(‘pysha3==1.0b1’), {‘merkletools’})

do you fixed broh???