Help: python error signing certificates with cert.issuer

Hello I am using blockcerts, I had to switch from windows to ubuntu and using python 3.12.
I have already created a template and I have filled it with information. Now I’m trying to sign it with cert-issuer. I am using Ethereum on the Sepolia testnet.

However, when I run this command:

python cert_issuer -c conf.ini

I get the following response:

(venv) vboxuser@Ubuntu:~/Documentos/blockcerts-v2/cert-issuer$ python cert_issuer -c conf.iniWARNING - Your app is configured to skip the wifi check when the USB is plugged in. Read the documentation to ensure this is what you want, since this is less secureINFO - This run will try to issue on the ethereum_sepolia chainTraceback (most recent call last): File “/usr/lib/python3.10/”, line 196, in _run_module_as_main return _run_code(code, main_globals, None, File “/usr/lib/python3.10/”, line 86, in _run_code exec(code, run_globals) File “/home/vboxuser/Documentos/blockcerts-v2/cert-issuer/cert_issuer/”, line 21, in cert_issuer_main() File “/home/vboxuser/Documentos/blockcerts-v2/cert-issuer/cert_issuer/”, line 17, in cert_issuer_main issue_certificates.main(parsed_config) File “/home/vboxuser/Documentos/blockcerts-v2/cert-issuer/venv/lib/python3.10/site-packages/cert_issuer/”, line 30, in main certificate_batch_handler, transaction_handler, connector = ethereum.instantiate_blockchain_handlers(app_config) File “/home/vboxuser/Documentos/blockcerts-v2/cert-issuer/venv/lib/python3.10/site-packages/cert_issuer/blockchain_handlers/ethereum/”, line 64, in instantiate_blockchain_handlers certificate_handler=CertificateV3Handler(),TypeError: CertificateV3Handler.init() missing 1 required positional argument: ‘app_config’

it’s already solved (〜 ̄▽ ̄)〜

1 Like

I also had a similar incident. How did you solve it? please tell me.

this file shows a minimum viable config file (for mocknet):

Maybe this will help?