Android wallet source code [SOLVED]


#1

Hi all,
Can anyone tell me how to run the app in AndroidStudio?. I ran the build.sh file and the project build successfully. I am getting the cannot resolve symbol error for most of the libraries. Can anyone help here please?

Regards,
Ankit.


#2

Hi Ankit,
It looks like this is injected in the gradle build by setting the app id for dev, staging, or production (env), but it does seem like we’re missing some info in the README.

@downie my android dev env is out of date and the build failed for me (not directly because of this; rather my paths are out of date). Do you happen to know? If not, I can get my environment in order and find out.

Ankit, fyi, that class is defined in these locations:

https://github.com/blockchain-certificates/wallet-android/blob/master/LearningMachine/app/src/<dev|staging|production>/java/com/learningmachine/android/app/data/inject/LMComponent.java

#3

Hm. I’ll take a look after my morning meetings. I know the build requires some pre-release software (Android Studio 3.0 Preview & the respective gradle beta) but I didn’t have any build issues when I last checked.

I’ll let you know what I find out.


#4

Hey @ankitx3,

Try downloading the latest from master & trying again. I updated the config file to the latest Android Studio & gradle versions. After that, I was able to get the devDebug environment to build without issue.

(Also of note: the build.sh file is for building from the command line – you shouldn’t need to run it directly if you’re building directly from Android Studio.)

Let me know if this doesn’t fix your issue.

Thanks!
Chris


#5


Hi Chris, I pulled the latest changes and again ran build.sh file.
The Junit test cases are failing but the build.sh files runs successfully(Build is successful) when I comment out every junit test file.
When I run the make module main from Android Studio, it throws errors as shown in the screenshot.
Please help!.

Regards,
Ankit.


#6

I downloaded the latest Android Studio 3.0 and every issue got resolved.
Thanks Chris and Kim. :slight_smile: