Broadcasting failed. go into a loop to rerun cert-issuer


#1

Hi,

I tried to issue certificates on testnet. It successfully issued certificates before, but it just didn’t work sometimes with the exact same config settings. And I tried a lot of times, it worked occasionally, almost drove me crazy.

  • I have enough balance in my address: mhK46hom8wPRKVAdmvnwUeB4vNEayNeagK
  • And I set conf.ini files in cert-tools and cert-issuer correctly.

Anyone encountered the same problem before or have ideas on it?

thanks,


#2

Sometimes, those blockchain explorers can be pretty flaky. Your configs are probably fine, but you might want to try to hit some of those endpoints manually (with curl or maybe a browser) to see what kind of response you’re getting at the moment. I might be missing something, but it’s usually the public blockchain explorers.


#3

Thank you very much!

Could you elaborate a little bit more?
What do you mean

hit some of those endpoints manually

Thanks,


#4

It can be a little bit tough to figure it out from the code, but if you hit, say, the Blockexplorer API directly, it might come back either with a JSON response payload, or with a 404 (or something else). They can flake out sometimes, so if you’re seeing this behavior in cert-issuer, it might be worth checking those sites to see if they’re up.

A testnet example might be https://testnet.blockexplorer.com/api/tx/152239c868ba6ea0357a88dd2fa45048dbc726603930f2c2f1225ca92023e6d9


#5

thanks.
now it works again for unknown reason