Unable issue certificate

Hi All,

I am running cert-issuer on docker. I followed steps which are provided in github https://github.com/blockchain-certificates/cert-issuer.
I am unable issue certificate, because am getting following error when I run " cert-issuer -c /etc/cert-issuer/conf.ini" command.

bash-4.3# cert-issuer -c /etc/cert-issuer/conf.ini
Traceback (most recent call last):
File “/usr/bin/cert-issuer”, line 11, in
load_entry_point(‘cert-issuer==2.0.9’, ‘console_scripts’, ‘cert-issuer’)()
File “/usr/lib/python3.5/site-packages/cert_issuer/main.py”, line 14, in cert_issuer_main
from cert_issuer import config
File “/usr/lib/python3.5/site-packages/cert_issuer/config.py”, line 6, in
from cert_schema import BlockchainType, Chain, chain_to_bitcoin_network, UnknownChainError
ImportError: cannot import name ‘BlockchainType’

This looks like an old version of the code – we haven’t had a file named main.py for a while. This can happen if there are old docker images left around. I run this to clear out old images and containers:


docker rm -v $(docker ps -a -q -f status=exited)

docker run -v /var/run/docker.sock:/var/run/docker.sock -v /var/lib/docker:/var/lib/docker --rm martin/docker-cleanup-volumes