I have a 24-word seed and I'm trying to restore, but the app says it's invalid

Hello Blockcerts community,

I got a degree in 2020 (still have the .json), and at some point I uninstalled the blockcerts app or got a new phone. Fine, I thought, I have the seed stored in my password manager.

Today I went to restore and it doesn’t work! “Passphrase Invalid”. This is the Blockcerts app on Android 11+, I click “current user” on the first-run screen and then paste in the 24-word seed I have.

I see elsewhere in the docs (https://www.blockcerts.org/about-passphrase) it mentions 12-16 words.

Any ideas about what’s going on?

Where did you get the 24-word seed?
To the best of my knowledge, the HD wallet only generates 12-word seeds.

With a fresh install it generates 24-word seeds

Ok I need to do some investigation on the matter, but that might not be too immediate as I have other things lingering

@tfar_234, on what platform did you get your original seed (iOS or Android)?

I got it on Android originally.

Ok so I tried today, the wallet indeed gives a 24-word seed.

I tried saving a local file, then recreating the wallet and it worked.
I tried saving the passphrase and copy pasting to recreate the wallet and it worked.

Are you tech savvy? If so it’d be great if you could clone this repo:

Then modify this line https://github.com/blockchain-certificates/did-generator/blob/master/key-management/generateKeyPair.ts#L50 so that mnemonic = 'YOUR SEED'

Then npm run generate:keyPair

Then in the output you should see this message “'bitcoin address generated”, with an address following. That address should theoretically match the one in your certificate json file, in the recipient field.

Also just to make sure, you do have the latest version of the app available from the Play Store?

What’s your current Android version?

My current Android version is 13

I am tech-savvy and can definitely do that for you, but it will take a week, possibly three weeks, until I have time!

@tfar_234 we have released a new version of the app which fixes a permission bug on Android 13.

We have in the process tested your issue but weren’t able to replicate it (on emulator and actual machines).