Create Issuing Address issue



Just trying to work through the tutorail in the cert-issuer section and am encountering an issue at the
"bitcoin-cli dumpprivkey $issuer > /etc/cert-issuer/pk_issuer.txt " section…
I get an error of -1 when I try this.

I have docker installed and at the Bash cli, have ran the cert-issuer, and have created a Bitcoin Issuing address and added it to the conf.ini file in the issuing_address section.

Any suggestions would be appreciated. have i missed something in the steps that I should have done before this?



Hi … just to add to this.

When I run the command:
issuer=bitcoin-cli getnewaddress
This seems to take.

The Second line is where the error initiates.

However. … if I run the bitcoin-cli command - bitcoin-cli getaccountaddress "issuer" - it returns a valid address.
If I run bitcoin-cli dumpprivkey “issuer” - it returns the error.

If I run the bitcoin-cli dumpprivkey _issuer address obtained from getaccountaddress_ - it works.

Any suggestions as to why the dumpprivkey is not recognising the $Issuer variable?



Hi the lines you are mentioned are doing following thinngs

  1. Creating a new address
  2. Assigning it to issue varibale
  3. getting private key using the variable in step 2
  4. saving it in the text file /etc/cert-issuer/pk_issuer.txt

if you are facing issues in running the scripts then try to do these steps manually. Hope this help