Code changes not getting reflected for Cert-Issuer

I am trying todo some changes in Cert-Issuer module.

I checked cert-issuer/ file which says :

‘console_scripts’: [
'cert-issuer = cert_issuer.main:cert_issuer_main’,

So I changed cert_issuer/ file and added a at line 23.

But I cannot see this change reflected when I issue the certificate : cert-issuer -c conf_ethtest.ini

Do I need to do something else to reflect the code changes like build the code ?
or I am looking at some wrong place?

Try to run pip install .
Maybe there are better way, but that would rebuild your code

1 Like

Thanks @jkwan running pip3 install . Worked.
I can see my changes now.

Next I am facing another issue while running cert issuer.

If I try to issue certificate via command cert-issuer -c conf_ethtest.ini
I am able to generate the certificate.

But if I try to issue certificate by command python3 cert_issuer/
I get error - No module named chainpoint.

I am not sure why this error is coming and that to ModuleNotFound.

How can I issue Ethereum certificate by directly running a python (.py) file

I tried as I believe this file is the entry point for issuing certificate.