Cert-viewer - no module named req


#1

I face problem when trying out this command.

pip install .

it generates an output saying
from pip.req import parse_requirements
ImportError: No module named req

command “python setup.py egg_info” failed with error code 1 … "

anyone could guide me on how to solve this ?

thanks


#2

This looks like an error I encountered as well. Was able to solve it by ensuring the setup.py file was in my path.
The downloaded container installs both python 2.7 as well as 3 but your path may only be looking at the 2.7 install. That’s as instructive as I can get at this point as I’m a novice but If I have more I’ll add it later.


#3

Thank you for your guidance.

Just wanted to clear my doubt. the setup.py from cert-viewer I should add in environment variable path is it ? I’m sorry if i sounds like a dumb.


#4

Right, I think that’s what’s going on. and BTW-it doesn’t sound dumb b/c I barely understand it! That said, I tried to invoke the error again but was unable to do so.


#5

Here’s my current path: /Library/Frameworks/Python.framework/Versions/3.6/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/go/bin:/Users/iain/go/bin

Here’s a post on StackOverflow that addresses the path issue as well.
My alias python used to represent python2.7 (located in /usr/bin). However the default python_path is now preceded by /usr/local/bin for python3; hence when typing python, I didn’t get either the python version.

I tried make a link in /usr/local/bin for python2:

ln -s /usr/bin/python /usr/local/bin/

It works when calling python for python2


#6

Hi folks,
Sorry for the delay – note that there was a problem with the dependencies, which needed to be updated. Can you re-sync the repo and try again?

thanks,
Kim