How to generate unsigned certificate


#1

hello people
I run cert-tools, and can’t create unsigned certificate, I run command instantiate-certificate-batch -c conf.ini like in documentation, and the result is here

but when I go to the unsigned_certificates folder I don’t see nothing like this.


my conf.ini is here.

please help me.

regards
Angel


#2

Did you put any data on your roster (utepsa.csv) ? Also did you generate your template?


#3

Hi reypadilla.

yes, I did put data in my utepsa.csv file, like this

yes I did generate my template succesfully, like this

do you know what happen with this problem, please

regards
Angel


#4

Can you try to use the default roster and default configuration for conf.ini ?

Also in conf.ini comment this out by adding # on the start, so you don’t need to add anything on the roster.

additional_per_recipient_fields = {“fields”: [{“path”: “$.assertion.evidence”,“value”: “|EVIDENCE|”,“csv_column”: “evidence”}]}

your roster…csv should look like this

name,pubkey,identity
John Doe, 1asdsdbks3fdf, johondoe@email.com


#5

Hi reypadilla

I change my conf.ini like default, and add in my .csv your data example, I did run the script like this images:

in my conf.ini like this a part roster

well and again nothing, this is my files and the root like a roster in conf.ini

please help me.

regards
Angel


#6

Hi Angel,

I’ll try to clone cert-tools again and test. They may have change something.


#7

Hi Angel,

I did a quick test and cloned cert-tool and it looks like everything has change and I’m getting the same no certificate on the folder. I’ll see what I can do If I can manage to generate an unsigned certificate otherwise may need to contact the main dev.

My old cert-tool is still working though…


#8

Hi folks,
I took a look and there was an issue with determining the base path (relative to the config file). I just fixed, confirmed it works, and pushed an update.

Please resync and retry.

  • Kim