Cert-issuer Error


#1

Hi there,

I’m trying to use the cert-issuer program to issue some certificates on the testnet but I get this error

raise UnableToSignTxError('Unable to sign transaction') cert_issuer.errors.UnableToSignTxError: Unable to sign transaction

The inputs generated before signing the transaction are:

inputs : [Spendable<325 mbtc "e92ddcc3f675bcde9724927f1ed05637251e1bc64ef902580a4a010cdc84da63:0" 0/0/0>]

The decoded transaction

    {
   "lock_time":0,
   "size":128,
   "inputs":[
      {
         "prev_out":{
            "index":0,
            "hash":"e92ddcc3f675bcde9724927f1ed05637251e1bc64ef902580a4a010cdc84da63"
         },
         "script":""
      }
   ],
   "version":1,
   "vin_sz":1,
   "hash":"750173e73e662706f5044222aa8b04ac7cfe968d177b457ad1e81631584a78ff",
   "vout_sz":2,
   "out":[
      {
         "script_string":"OP_DUP OP_HASH160 7c7b8163753242da521c5919a6f4cd9deb62658c OP_EQUALVERIFY OP_CHECKSIG",
         "address":"1CMCk6U6dtTtozexvhw3SgZU55mVpTjw3b",
         "value":32440000,
         "script":"76a9147c7b8163753242da521c5919a6f4cd9deb62658c88ac"
      },
      {
         "script_string":"OP_RETURN b592c04d71dc553b2835e353532e3439f353fd13d569b9ef8ce6183c98eb8530",
         "value":0,
         "script":"6a20b592c04d71dc553b2835e353532e3439f353fd13d569b9ef8ce6183c98eb8530"
      }
   ]
}

UPDATE

I decided to use a different address and somehow it worked. I am not to sure why but it is something to look into.


#2

Hi Noah,
This happens if the private key for the transaction input you’re trying to spend isn’t available. The signing process signs all the inputs it can, but if it detects a transaction input couldn’t be signed, it fails with that message.

What happened mostly likely is that the private key for the address you tried to spend was not in the right (file) location.

Thanks,
Kim


#3

Woops :slight_smile: I was looking in the wrong area. I probably lost the key when I restarted the docker image.

Thanks for the answer!


#4

where should i put the private key ?


#5

There is txt file (Pk_issuer.txt) in the cert-issuer folder, you should paste the PK there


#6

This is the config file

10%20PM

when i try to look for this file … i didn’t find it :sweat:


#7

don’t worry … i solved the problem


#8

That is the config.ini file, in the Cert-Issuer Folder there should be a Pk_issuer.txt file.


#9

when i look in the https://live.blockcypher.com/ using my public key…

i see the transaction … do i need to wait until it is confirmed then i can use the verify button in cert-viewer ?