Blockcert testnet issues


I read several articles here and tried a lot, none does solve my problem.

% python cert_issuer/ -c conf.ini
WARNING - Your app is configured to skip the wifi check when the USB is plugged in. Read the documentation to ensure this is what you want, since this is less secure
INFO - This run will try to issue on the bitcoin_testnet chain
INFO - Set cost constants to recommended_tx_fee=0.000600,min_per_output=0.000028,satoshi_per_byte=250
INFO - Processing 2 certificates
INFO - Processing 2 certificates under work path=/Users/flaviospirgi/Documents/mit-certs/cert-issuer/data/work
WARNING - <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer certificate (_ssl.c:1051)>
WARNING - address mnjA737RZoJ6iNaFogLLWtg8kv9DhoFgTo has a balance of 0
INFO - Total cost will be 133500 satoshis
ERROR - Please add 133500 satoshis to the address mnjA737RZoJ6iNaFogLLWtg8kv9DhoFgTo
ERROR - Please add 133500 satoshis to the address mnjA737RZoJ6iNaFogLLWtg8kv9DhoFgTo
Traceback (most recent call last):
File “cert_issuer/”, line 44, in <module>
tx_id = main(parsed_config)
File “cert_issuer/”, line 36, in main
return issue(app_config, certificate_batch_handler, transaction_handler)
File “cert_issuer/”, line 16, in issue
File “/Users/flaviospirgi/Documents/mit-certs/cert-tools/venv/lib/python3.7/site-packages/cert_issuer-2.0.15-py3.7.egg/cert_issuer/blockchain_handlers/bitcoin/”, line 51, in ensure_balance
raise InsufficientFundsError(error_message)
cert_issuer.errors.InsufficientFundsError: Please add 133500 satoshis to the address mnjA737RZoJ6iNaFogLLWtg8kv9DhoFgTo

I do have funds on mnjA737RZoJ6iNaFogLLWtg8kv9DhoFgTo. It could have something to do with the CERTIFICATE_VERIFY_FAILED error for which I did not find anything here. I even generated a new key and it still fails. After trying everything I could after reading similar issues here I am running out of ideas. Am I not seeing anything obvious?

Many thanks!


Please review below thread.

Let me know if it helps.

Hi Danish,

Thank you. I indeed already saw this thread and tried the things in there (like playing around with the bitcoind variable) but it didn’t help so far.

Kind regards,

Try removing this property and instead add below


If it didnt help, share your configuration

Thanks, but it didn’t help.

Here’s the configuration:

issuing_address = mnjA737RZoJ6iNaFogLLWtg8kv9DhoFgTo




usb_name = /Users/fspirgi/Documents/mit-certs/cert-issuer
key_file = .pk_issuer



Looks like urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] is your problem. Sounds like when trying to get the balance of your wallet, it’s hitting that error. Thus it doesn’t think you have a balance since it couldn’t resolve the url.

I’d google that error and see what comes of it. For example, here’s one:

Thanks. Yes, that’s what I thought it could be. But: This file contains the private key, checked it at least twice, looks fine and also has those required 52 bytes I learned those keys should have. Not sure whether it’s correct to check them with ssl libraries, maybe the key should have another format? Also tried to google that but didn’t find a hint (that I could understand).

This error doesn’t appear to have anything to do with the bitcoin/ethereum private key. Looks like it’s a problem using python’s requests library when hitting an HTTPS endpoint.

So, seems I’m looking at the wrong thing. Will try to find out where exactly the problem occurs. Many thanks in the meantime!