# Merkletools dependences pysha3

**URL:** <https://community.blockcerts.org/t/merkletools-dependences-pysha3/649>\
**Category:** Support\
**Created:** [December 22, 2017, 10:46am UTC](https://community.blockcerts.org/t/merkletools-dependences-pysha3/649 "2017-12-22T10:46:08Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![enriquelizaso](https://avatars.discourse-cdn.com/v4/letter/e/0ea827/32.png) [@enriquelizaso](https://community.blockcerts.org/u/enriquelizaso)\
**Post date:** [December 22, 2017, 10:46am UTC](https://community.blockcerts.org/t/merkletools-dependences-pysha3/649/1 "2017-12-22T10:46:09Z")

</div>

Hi there!

I’m trying to install cert-issuer, but when I run “python [setup.py](http://setup.py) install”, I get the following error:

Processing dependencies for cert-issuer==2.0.11  
error: pysha3 1.0.2 is installed but pysha3==1.0b1 is required by {‘merkletools’}

I’m running on a Windows, virtualenv enabled for python 3.6.3. This question is the same that appeared in a different thread (No module named ‘cert\_issuer’), but it looks like remain unanswered. Could somebody please give me a hint about how to solve it?

Regards,

Enrique

---

<div class="post-metadata">

**Author:** ![enriquelizaso](https://avatars.discourse-cdn.com/v4/letter/e/0ea827/32.png) [@enriquelizaso](https://community.blockcerts.org/u/enriquelizaso)\
**Post date:** [December 22, 2017, 4:45pm UTC](https://community.blockcerts.org/t/merkletools-dependences-pysha3/649/2 "2017-12-22T16:45:58Z")

</div>

Ok, solved by now in \*WINDOWS". I don’t know whether it is the best way or not, but that’s how I went over it:

- Good to know, the issue is about two conflicting libraries in the project. Merkletools requires “exactly” pysha3 1.01b, while cert-tools require pysha3 1.0.2 or greater
- I used “pip install cert-issuer” instead “python [setup.py](http://setup.py) install”
- I tried the force-brute approach: I went to C:\Users"user"\AppData\Local\Programs\Python\Python36\Lib\site-packages\merkletools-1.0.2-py3.6.egg\EGG-INFO, and open “requires.txt” with a text editor (wordpad will do). Change the contents inside to pysha3==1.0.2 (maybe \>= would be better)

That’s all. Sure, there should be better ways to solve the problem…

---

<div class="post-metadata">

**Author:** ![dannysuarez](https://sea2.discourse-cdn.com/flex016/user_avatar/community.blockcerts.org/dannysuarez/32/558_2.png) [@dannysuarez](https://community.blockcerts.org/u/dannysuarez)\
**Post date:** [May 4, 2018, 4:32pm UTC](https://community.blockcerts.org/t/merkletools-dependences-pysha3/649/3 "2018-05-04T16:32:07Z")

</div>

Hi Guys,  
Im facing the same problem in mac os.  
Processing dependencies for cert-issuer==2.0.12  
error: pysha3 1.0.2 is installed but pysha3==1.0b1 is required by {‘merkletools’}

I´ve already run pip install cert-issuer and python setup.py 2 install but both didnt for for me.  
Regards,

---

<div class="post-metadata">

**Author:** ![aronning](https://avatars.discourse-cdn.com/v4/letter/a/47e85d/32.png) [@aronning](https://community.blockcerts.org/u/aronning)\
**Post date:** [May 4, 2018, 4:43pm UTC](https://community.blockcerts.org/t/merkletools-dependences-pysha3/649/4 "2018-05-04T16:43:52Z")

</div>

@dannysuarez,

For the time being, try using the above approach. There’s some clashing going on with some dependencies, and the docker image seems to take care of it manually with this line:

`sed -i.bak s/==1\.0b1/\>=1\.0\.2/g /usr/lib/python3.*/site-packages/merkletools-1.0.2-py3.*.egg-info/requires.txt`

Alternatively, another approach is to manually update chainpoint’s dependency to 1.0.3. Unfortunately I do not know why it’s trying to use a previous version of merkeltools.

`vi /usr/local/lib/python3.6/site-packages/chainpoint-0.0.2.dist-info/METADATA`

Change to `merkletools (==1.0.2)` to `merkletools (>=1.0.3)`

---

<div class="post-metadata">

**Author:** ![aronning](https://avatars.discourse-cdn.com/v4/letter/a/47e85d/32.png) [@aronning](https://community.blockcerts.org/u/aronning)\
**Post date:** [May 4, 2018, 4:59pm UTC](https://community.blockcerts.org/t/merkletools-dependences-pysha3/649/5 "2018-05-04T16:59:43Z")

</div>

Opened up an issue tracking it here: [https://github.com/lontivero/PyChainpoint/issues/2](https://github.com/lontivero/PyChainpoint/issues/2)

---

<div class="post-metadata">

**Author:** ![kjallawaram](https://sea2.discourse-cdn.com/flex016/user_avatar/community.blockcerts.org/kjallawaram/32/354_2.png) [@kjallawaram](https://community.blockcerts.org/u/kjallawaram)\
**Post date:** [May 4, 2018, 6:16pm UTC](https://community.blockcerts.org/t/merkletools-dependences-pysha3/649/6 "2018-05-04T18:16:39Z")

</div>

@dannysuarez

I am using Mac OS too.

There is no requires.txt file in /site-packages/merkletools-1.0.2-py3.\*.egg-info folder. I tried changing the chainpoint METADATA file too. But it still shows the same issue.

I am getting this error when I run cert-issuer -c conf.ini

pkg\_resources.ContextualVersionConflict: (pysha3 1.0.2 (/Users/kjallawaram/Karthik/BlockChain/cert-issuer/venv/lib/python3.6/site-packages), Requirement.parse(‘pysha3==1.0b1’), {‘merkletools’})

---

<div class="post-metadata">

**Author:** ![Chidoman](https://sea2.discourse-cdn.com/flex016/user_avatar/community.blockcerts.org/chidoman/32/752_2.png) [@Chidoman](https://community.blockcerts.org/u/Chidoman)\
**Post date:** [April 12, 2021, 11:57am UTC](https://community.blockcerts.org/t/merkletools-dependences-pysha3/649/7 "2021-04-12T11:57:50Z")

</div>

do you fixed broh???
