# Cert issuer error not enough satoshis with Bitcoin Core wallet - URGENT!

**URL:** <https://community.blockcerts.org/t/cert-issuer-error-not-enough-satoshis-with-bitcoin-core-wallet-urgent/521>\
**Category:** Support\
**Created:** [November 10, 2017, 12:51pm UTC](https://community.blockcerts.org/t/cert-issuer-error-not-enough-satoshis-with-bitcoin-core-wallet-urgent/521 "2017-11-10T12:51:12Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![nikolak](https://avatars.discourse-cdn.com/v4/letter/n/5f8ce5/32.png) [@nikolak](https://community.blockcerts.org/u/nikolak)\
**Post date:** [November 10, 2017, 12:51pm UTC](https://community.blockcerts.org/t/cert-issuer-error-not-enough-satoshis-with-bitcoin-core-wallet-urgent/521/1 "2017-11-10T12:51:12Z")

</div>

Dear,  
I’ve already asked here about problem with satoshis here: [Cert issuer error not enough satoshis](http://community.blockcerts.org/t/cert-issuer-error-not-enough-satoshis/508)

According to this thread: [Not enough satoshis? [SOLVED]](http://community.blockcerts.org/t/not-enough-satoshis-solved/244)  
we have installed Bitcoin Core wallet and created address (transferred money to that address…)

But we still get identical error:

**bash-4.3# cert-issuer -c conf.ini**  
**WARNING - Your app is configured to skip the wifi check when the USB is plugged in. Read the documentation to ensure this is what you want, since this is less secure**  
**INFO - This run will try to issue on the bitcoin\_regtest chain**  
**INFO - Set cost constants to recommended\_tx\_fee=0.000600,min\_per\_output=0.000028,satoshi\_per\_byte=250**  
**INFO - Set cost constants to recommended\_tx\_fee=0.000600,min\_per\_output=0.000028,satoshi\_per\_byte=250**  
**INFO - Processing 38 certificates**  
**INFO - Processing 38 certificates**  
**INFO - Processing 38 certificates under work path=/cert-issuer/work**  
**INFO - Processing 38 certificates under work path=/cert-issuer/work**  
**WARNING - {‘code’: -5, ‘message’: ‘Invalid Bitcoin address: 1MgXUUgAv7YpKMHfb8SKyZgmsbpKtteRrZ’}**  
**WARNING - {‘code’: -5, ‘message’: ‘Invalid Bitcoin address: 1MgXUUgAv7YpKMHfb8SKyZgmsbpKtteRrZ’}**  
**WARNING - address 1MgXUUgAv7YpKMHfb8SKyZgmsbpKtteRrZ has a balance of 0**  
**WARNING - address 1MgXUUgAv7YpKMHfb8SKyZgmsbpKtteRrZ has a balance of 0**  
**INFO - Total cost will be 133500 satoshis**  
**INFO - Total cost will be 133500 satoshis**  
**ERROR - Please add 133500 satoshis to the address 1MgXUUgAv7YpKMHfb8SKyZgmsbpKtteRrZ**  
**ERROR - Please add 133500 satoshis to the address 1MgXUUgAv7YpKMHfb8SKyZgmsbpKtteRrZ**  
**Traceback (most recent call last):**  
\*\* File “/usr/bin/cert-issuer”, line 11, in \*\*  
\*\* load\_entry\_point(‘cert-issuer==2.0.11’, ‘console\_scripts’, ‘cert-issuer’)()\*\*  
\*\* File “/usr/lib/python3.6/site-packages/cert\_issuer/ **main**.py”, line 17, in cert\_issuer\_main\*\*  
\*\* issue\_certificates.main(parsed\_config)\*\*  
\*\* File “/usr/lib/python3.6/site-packages/cert\_issuer/issue\_certificates.py”, line 52, in main\*\*  
\*\* return issue(app\_config, certificate\_batch\_handler, transaction\_handler)\*\*  
\*\* File “/usr/lib/python3.6/site-packages/cert\_issuer/issue\_certificates.py”, line 30, in issue\*\*  
\*\* transaction\_handler.ensure\_balance()\*\*  
\*\* File “/usr/lib/python3.6/site-packages/cert\_issuer/bitcoin/transaction\_handlers.py”, line 51, in ensure\_balance\*\*  
\*\* raise InsufficientFundsError(error\_message)\*\*  
**cert\_issuer.errors.InsufficientFundsError: Please add 133500 satoshis to the address 1MgXUUgAv7YpKMHfb8SKyZgmsbpKtteRrZ**

Please check our conf.ini:  
**issuing\_address = 1MgXUUgAv7YpKMHfb8SKyZgmsbpKtteRrZ**

**# put your unsigned certificates here for signing. Default is /data/unsigned\_certificates**  
**unsigned\_certificates\_dir=/cert-issuer/data/unsigned\_certificates**  
**# signed certificates are the output from the cert signing step; input to the cert issuing step. Default is /data/signed\_certificates**  
**signed\_certificates\_dir=/cert-issuer/data/signed\_certificates**  
**# final blockchain certificates output. Default is /data/unsigned\_certificates**  
**blockchain\_certificates\_dir=/cert-issuer/data/blockchain\_certificates**  
**# where to store intermediate files, for debugging and checkpointing. Default is /data/work**  
**work\_dir=/cert-issuer/work**

**usb\_name = /cert-issuer/**  
**key\_file = pk\_issuer.txt**

**# which Bitcoin blockchain; regtest is default**  
**bitcoin\_chain=mainnet**  
**#bitcoin\_chain=regtest**

**# this disables the wifi check, and should only be used recommended during testing**  
**no\_safe\_mode**

**bitcoind = False**

Please if you have any suggestion what to do. It is very very urgent, please help!

Regards

Nikola

---

<div class="post-metadata">

**Author:** ![Brinkkemper](https://avatars.discourse-cdn.com/v4/letter/b/ed8c4c/32.png) [@Brinkkemper](https://community.blockcerts.org/u/Brinkkemper)\
**Post date:** [November 10, 2017, 1:37pm UTC](https://community.blockcerts.org/t/cert-issuer-error-not-enough-satoshis-with-bitcoin-core-wallet-urgent/521/2 "2017-11-10T13:37:10Z")

</div>

> INFO - This run will try to issue on the bitcoin\_regtest chain

This means that the argument for the mainnet is not properly parsed.

Are you using the latest version? If so, you will need to change:

bitcoin\_chain=mainnet  
to:  
blockchain = bitcoin\_mainnet

If you are not using the latest version, you can try and update to it, to see if that works

---

<div class="post-metadata">

**Author:** ![nikolak](https://avatars.discourse-cdn.com/v4/letter/n/5f8ce5/32.png) [@nikolak](https://community.blockcerts.org/u/nikolak)\
**Post date:** [November 10, 2017, 2:15pm UTC](https://community.blockcerts.org/t/cert-issuer-error-not-enough-satoshis-with-bitcoin-core-wallet-urgent/521/3 "2017-11-10T14:15:53Z")

</div>

Dear,  
thanks a lot for your quick answer.  
Yes I’m working with the latest version of cert-issuer and it works with regtest without problems (I get the certificates…).  
I’ve just tested it with blockchain = bitcoin\_mainnet and still the same error ;(.

Please do you have any other clue?

Regards

Nikola

---

<div class="post-metadata">

**Author:** ![nikolak](https://avatars.discourse-cdn.com/v4/letter/n/5f8ce5/32.png) [@nikolak](https://community.blockcerts.org/u/nikolak)\
**Post date:** [November 10, 2017, 5:57pm UTC](https://community.blockcerts.org/t/cert-issuer-error-not-enough-satoshis-with-bitcoin-core-wallet-urgent/521/4 "2017-11-10T17:57:49Z")

</div>

It calls mainnet now, but still same error ;( :

INFO - T **his run will try to issue on the bitcoin\_mainnet chain**  
INFO - Set cost constants to recommended\_tx\_fee=0.000600,min\_per\_output=0.000028,satoshi\_per\_byte=250  
INFO - Set cost constants to recommended\_tx\_fee=0.000600,min\_per\_output=0.000028,satoshi\_per\_byte=250  
INFO - Processing 38 certificates  
INFO - Processing 38 certificates  
INFO - Processing 38 certificates under work path=/cert-issuer/work  
INFO - Processing 38 certificates under work path=/cert-issuer/work  
WARNING - {‘code’: -5, ‘message’: ‘Invalid Bitcoin address: 1MgXUUgAv7YpKMHfb8SKyZgmsbpKtteRrZ’}  
WARNING - {‘code’: -5, ‘message’: ‘Invalid Bitcoin address: 1MgXUUgAv7YpKMHfb8SKyZgmsbpKtteRrZ’}  
WARNING - address 1MgXUUgAv7YpKMHfb8SKyZgmsbpKtteRrZ has a balance of 0  
WARNING - address 1MgXUUgAv7YpKMHfb8SKyZgmsbpKtteRrZ has a balance of 0  
INFO - Total cost will be 133500 satoshis  
INFO - Total cost will be 133500 satoshis  
ERROR - Please add 133500 satoshis to the address 1MgXUUgAv7YpKMHfb8SKyZgmsbpKtteRrZ  
ERROR - Please add 133500 satoshis to the address 1MgXUUgAv7YpKMHfb8SKyZgmsbpKtteRrZ  
Traceback (most recent call last):  
File “/usr/bin/cert-issuer”, line 11, in   
load\_entry\_point(‘cert-issuer==2.0.11’, ‘console\_scripts’, ‘cert-issuer’)()  
File “/usr/lib/python3.6/site-packages/cert\_issuer/ **main**.py”, line 17, in cert\_issuer\_main  
issue\_certificates.main(parsed\_config)  
File “/usr/lib/python3.6/site-packages/cert\_issuer/issue\_certificates.py”, line 52, in main  
return issue(app\_config, certificate\_batch\_handler, transaction\_handler)  
File “/usr/lib/python3.6/site-packages/cert\_issuer/issue\_certificates.py”, line 30, in issue  
transaction\_handler.ensure\_balance()  
File “/usr/lib/python3.6/site-packages/cert\_issuer/bitcoin/transaction\_handlers.py”, line 51, in ensure\_balance  
raise InsufficientFundsError(error\_message)  
cert\_issuer.errors.InsufficientFundsError: Please add 133500 satoshis to the address 1MgXUUgAv7YpKMHfb8SKyZgmsbpKtteRrZ

---

<div class="post-metadata">

**Author:** ![kim](https://sea2.discourse-cdn.com/flex016/user_avatar/community.blockcerts.org/kim/32/307_2.png) [@kim](https://community.blockcerts.org/u/kim)\
**Post date:** [November 11, 2017, 2:44am UTC](https://community.blockcerts.org/t/cert-issuer-error-not-enough-satoshis-with-bitcoin-core-wallet-urgent/521/5 "2017-11-11T02:44:09Z")

</div>

I think your installation is inconsistent. I noticed that you have [main.py](http://main.py) in the stack, which doesn’t exist. Try nuking your cert-issuer installation. and if you’re using docker, remove existing images and containers. Somewhere else in this forum I’ve given the commands; otherwise, google will help.

---

<div class="post-metadata">

**Author:** ![nikolak](https://avatars.discourse-cdn.com/v4/letter/n/5f8ce5/32.png) [@nikolak](https://community.blockcerts.org/u/nikolak)\
**Post date:** [November 11, 2017, 6:54am UTC](https://community.blockcerts.org/t/cert-issuer-error-not-enough-satoshis-with-bitcoin-core-wallet-urgent/521/6 "2017-11-11T06:54:52Z")

</div>

Dear Kim,  
thanks for the answer.  
I’me using docker at Mac (before that we hav stucked at Ubuntu with the same problem).  
I remove regularly all unnecessary docker instances. I do not know how I had included [main.py](http://main.py) into stuck?!  
I’ve been used the standard guidance:

git clone [https://github.com/blockchain-certificates/cert-issuer.git](https://github.com/blockchain-certificates/cert-issuer.git) && cd cert-issue  
docker build -t bc/cert-issuer:1.0 .  
docker run -it bc/cert-issuer:1.0 bash  
after that I start cert-issuer inside docker with (cert-issuer folder and all unsigned certificates are inside unsigned folder…):  
cert-issuer -c conf.ini

In regtest mode it works without problem than I do not know how to exclude [main.py](http://main.py) from the stuck.  
It looks like no communication with wallet by API. I do not have any firewall at machine. IS there any log inside docker to check possibe “hidden” errors?

Regards  
Nikola

---

<div class="post-metadata">

**Author:** ![d.hussain](https://avatars.discourse-cdn.com/v4/letter/d/4af34b/32.png) [@d.hussain](https://community.blockcerts.org/u/d.hussain)\
**Post date:** [November 13, 2017, 8:39am UTC](https://community.blockcerts.org/t/cert-issuer-error-not-enough-satoshis-with-bitcoin-core-wallet-urgent/521/7 "2017-11-13T08:39:49Z")

</div>

> [@nikolak](#):
>
> bitcoind = False

I noticed you are using bitcoind = False in your configuration. We faced the same earlier.  
I have not tried the suggestion [Blockcert on testnet - #10 by kim](http://community.blockcerts.org/t/blockcert-on-testnet/501/10) yet as manual modification worked for us.

---

<div class="post-metadata">

**Author:** ![nikolak](https://avatars.discourse-cdn.com/v4/letter/n/5f8ce5/32.png) [@nikolak](https://community.blockcerts.org/u/nikolak)\
**Post date:** [November 13, 2017, 11:48am UTC](https://community.blockcerts.org/t/cert-issuer-error-not-enough-satoshis-with-bitcoin-core-wallet-urgent/521/8 "2017-11-13T11:48:32Z")

</div>

Dear,  
thanks for your suggestions.  
At the end it started to work.  
What I did is next:

- installed the latest version of docker (probably not important)
- downloaded the latest version from git for any case (probably not importatnt)
- build docker without changing any of the files (not included my conf.ini and unsigned certificates)
- started docker and set [conf.in](http://conf.in) in /etc/cert-issuer folder together with pk\_issuer.txt file
- copied into docker container prepared unsigned certificates
- started cert-issuer -c /etc/cert-issuer/conf.ini

Probably I’ve made the mistake because I build docker with my conf.ini and prepared unsigned certificates - and started process with my conf.ini inside /cert-issuer folder (I did not use and change /etc/cert-issuer/conf.ini)

Probably it was the problem.

Thanks again for your support. 🙂  
Regards

Nikola
